Page 3 of 5 FirstFirst 12345 LastLast
Results 41 to 60 of 100

Thread: Touchscreen

  1. #41
    Junior Member
    Join Date
    Apr 2013
    Location
    Italy
    Posts
    3
    It was already with "read and Write" permissions..

    it looks like the android is reading the usb multi touch ir panel as HID mouse.... how could I "say to Mr android" to read my touch screen for real instead?

    As soon I setup the .idc file linked with the id 8883.0001, at the next reboot it even disapears the partial ability to get the "touch spot" during screen pressing.. (which it is without any movements)..



  2. #42
    Junior Member
    Join Date
    Apr 2013
    Location
    Italy
    Posts
    3
    it works with the "omegamoon" kernel 3.0.8 version, http://www.omegamoon.com/blog/index....y130210-223434

    on games it runs fast and perfect response, just added the idc with vendor and product founded in lsusb in terminal.

    BUTTT in "home" screen, the whole system runs very slowlyyyy with the Finless 1.7 Kernel it was super fast and smooth,

    any idea to integrate the omegamoon kernel touchscreen support to the Finless Kernel one?

    BOB??

  3. #43
    Junior Member
    Join Date
    Jun 2013
    Location
    NJ
    Posts
    1

    Acer T272HL

    Ive been trying also to get the ACER T272HL Multitouch to work. I too have to use 5 fingers. If I touch with one finger from one hand and then 4 on the other, I can use the single finger to move around. This is a bit annoying so Id like to see if anyone else found a solution.

    Thanks
    Chris

  4. #44
    Junior Member
    Join Date
    Jun 2013
    Location
    France
    Posts
    1

    HELP - IIYAMA T2250MTS with g box MX2

    Dear All,

    I'm new there... but trying to join the team putting together a 22 inch tablet at home.
    I just received my g box Midnight MX2 with Android 4.2.2 on it.
    I've plugged the T2250MTS, copied the file Vendor_0408_Product_3001.idc in /system/usr/idc and rebooted but nothing changed... the cursor is not moving at all
    Is there anything special to do? Any way to debug the problem step by step?
    lsusb give the proper 0408 : 3001 answer once the screen is plugged...

    I'm stuck there!!!
    Thanks for your help!

  5. #45
    Junior Member
    Join Date
    Jun 2013
    Location
    Hungary
    Posts
    6

    A much bigger touch screen, let say 50" :D

    Hi,

    As I was reading the comments I saw that you guys managed to connect touch capable displays with these your mini PCs.

    I have a MK808b, and was thinking if it would possible to connect an elastic touch foil the same way as you did with the monitors. These can be ordered in any size and form, and can be installed on a plexy glass, than I would use a projector to rear project the screen on the plexy. This way I could make a touch wall in my living room.

    touch foil:
    http://www.touchfoil.us

    Found some ready made mini pc for the use with touch foil:
    http://www.displaylite.co.uk/news/38...ndroid/d,News/

    Would it be possible?
    Regards,

  6. #46
    Junior Member
    Join Date
    Feb 2013
    Location
    United States
    Posts
    6
    Many thanks for all the detail. I'm running into a few issues trying to setup a TD2420 from Viewsonic and would appreciate any ideas/thoughts.

    Here's what I've done so far
    The lsusb command indicates the touchscreen has the following product/vendor numbers which show up only after I plug in the usb from the monitor:
    Product: 093a
    Vendor: 8002

    I've created the file in multiple ways with multiple names - all owned by root/root and with permissions 644:
    Product_093A_Vendor_8002.idc
    Product_093a_Vendor_8002.idc

    For the content, I initially tried in vi but the system file system is mounted ro (as an aside - I'd really appreciate the mount command / options to mount that as rw... I thought it was in the mnttab file, but I don't recall where that lives). I created it using the ES File Editor and confirmed that the trailing newline feed was present through a cat command from terminal editor. I also emailed the txt file to my google account, saved it locally, and copied and renamed (twice - using the names above).

    After every idc file change, I reboot and then unplug my mouse and plug in the monitor. I try using a single touch to move the cursor around the screen and activate apps - but do not appear to be getting any input.

    Still no luck. Thanks for any suggestions!

  7. #47
    Junior Member
    Join Date
    Jul 2013
    Location
    India
    Posts
    8

    MK808B support

    I am using MK808B dongle.

    - Can this mod work in the stock kernel? I am not able to flash the rom with Finless 1.7 till now (http://www.freaktab.com/showthread.p...Flashing-issue)

    - Can this mod work on a usb touch screen module listed in eBay (http://www.ebay.com/itm/7inch-4-Wire...item27c9355f9b)

    Thanks in advance.

  8. #48
    Member
    Join Date
    Oct 2012
    Location
    Rotterdam, Netherlands
    Posts
    73
    in theory yes.
    if it gives a white ring you can drag around it sould work.
    but if this panel is supported i have no idea.

    regards
    mark

  9. #49
    Member
    Join Date
    Jan 2013
    Location
    Europe
    Posts
    60
    ...but you will need root to add the file I think.

  10. #50
    Junior Member
    Join Date
    Jul 2013
    Location
    India
    Posts
    8
    I am using eGalax generic digitizer and controller with VendorID : 0eef and ProductID : 0001. I tried adding the vendor_0eef_product_0001.idc file to the system/usr/idc folder with the following content:


    touch.deviceType=touchScreen
    device.internal=1


    On rebooting its not responding to any touch input. I suspect the touch screen driver is missing. What else could be the reason?
    How can we check whether the touchscreen driver is already installed? Also is there any way to install the driver alone similar to Windows?

  11. #51
    Junior Member
    Join Date
    Aug 2013
    Location
    Belgium
    Posts
    6
    I'm having the same issue. Egalax touchscreen 0eef:0001. It is registered when inserted in USB, but not recognized by the system. So probably not driver...

    @Bob
    Is it possible to recompile a driver into the kernel?

  12. #52
    Junior Member
    Join Date
    Feb 2013
    Location
    United States
    Posts
    6
    I just flashed the 4.2.2 kernel on an MK808B - I was going to repeat the update process to see if that helped with the touchscreen recognition. I'll post success/failure...

    Do we even know what driver is required (or if the driver exists for Androids)?

  13. #53
    Junior Member
    Join Date
    Aug 2013
    Location
    Montevideo
    Posts
    1

    Question A little help over here..

    Guys, I made the same exact steps below, read the whole thread, even read also the help stuff on source.android.com and I have nothing working here.

    First of all, my hardware is an MK802 (im not really sure which version, but looking at the images i might say that is the first hardware they released) and i have an Acer T231H monitor. Now it's plugged like this:




    I made the lsusb thing and got the same vid and pid as in the post is described, vendor is 0408 and product is 3001, so the file is "Vendor_0408_product_3001.idc" and into the file there is the same string as in the first post.

    Even though I made the same exact steps as described, as I explained, I cannot manage to make this touchscreen work.

    Can anybody help me?

    Thank you guys in advance.

    PS: about the hub, i know it works with the touchscreen, because i tried it with my pc and it worked fine (trough the hub)

  14. #54
    Junior Member
    Join Date
    Oct 2013
    Location
    spain
    Posts
    1
    ok

  15. #55
    Member
    Join Date
    Jan 2013
    Location
    Europe
    Posts
    60
    @agusttt I can't see the picture you posted.

    A couple of things to check - even before you add the file but plug in the monitor can you see a ring which you can drag around on the screen? If you can't then the ROM kernel probably doesn't have the driver built in - but do try plugging it in direct to the USB on the stick as well.

    Just check that you've put the idc file in the right place as step 11 in the very first post has the path wrong - it should be /system/usr/idc I think.

    Check post 25 for some useful command lines - I'm probably teaching you to suck eggs but you have got root and mounted the /system/ partition read/write and changed the permissions - and best to check it is there after reboot - it does need a reboot to take affect.

    Finally did you create the idc file on the android stick or use windows - you need to use an editor that creates unix text file because of Windows CR/LF.

  16. #56
    Senior Member
    Join Date
    Nov 2012
    Location
    India
    Posts
    100
    I have a lenovo LI2341T 23" touchscreen monitor

    [ 3574.061174] usb 3-4: new high-speed USB device number 116 using xhci_hcd
    [ 3574.077491] usb 3-4: New USB device found, idVendor=058f, idProduct=6254
    [ 3574.077502] usb 3-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    [ 3574.078031] hub 3-4:1.0: USB hub found
    [ 3574.078119] hub 3-4:1.0: 4 ports detected

    [ 3574.364840] usb 3-4.3: new full-speed USB device number 117 using xhci_hcd
    [ 3574.383488] usb 3-4.3: New USB device found, idVendor=1926, idProduct=0336
    [ 3574.383499] usb 3-4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 3574.383505] usb 3-4.3: Product: Touchscreen
    [ 3574.383509] usb 3-4.3: Manufacturer: NextWindow
    [ 3574.388000] input: NextWindow Touchscreen as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.3/3-4.3:1.0/input/input16

    [ 3574.388350] hid-multitouch 0003:1926:0336.000A: input,hiddev0,hidraw0: USB HID v1.11 Mouse [NextWindow Touchscreen] on usb-0000:00:14.0-4.3/input0
    [ 3574.389800] input: NextWindow Touchscreen as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.3/3-4.3:1.1/input/input17
    [ 3574.390051] hid-generic 0003:1926:0336.000B: input,hiddev0,hidraw1: USB HID v1.11 Device [NextWindow Touchscreen] on usb-0000:00:14.0-4.3/input1
    [ 3574.391202] input: NextWindow Touchscreen as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.3/3-4.3:1.2/input/input18
    [ 3574.391509] hid-generic 0003:1926:0336.000C: input,hidraw2: USB HID v1.11 Mouse [NextWindow Touchscreen] on usb-0000:00:14.0-4.3/input2

    This is what I get when I connect my touchscreen to the USB hub.

    It seems, that two devices are getting created.
    058f:6254
    1926:0336

    I created both the files, and ofcourse using vi - so no issues of windows CR/EOL coming into the file.
    The permissions are as suggested 06775

    However, inspite of this - there seems to be no change. Even without these files in place, when one touches the screen the mouse cursor appears on the extreme left top corner of the screen. It cannot be moved, changed or any other operation for that matter. The same behaviour remains, even when the files are created.

    Any thoughts ?

    Alok

  17. #57
    Junior Member
    Join Date
    Oct 2013
    Location
    Canada
    Posts
    2

    WHere is the file todownload

    Hi, Where is the download file Everyone is talking about, I havent's seen any file to download

    Thanks

    I have a acer T232 HLadn wich to enalble support for Android. Any body make it wirk?

  18. #58
    Member
    Join Date
    Oct 2012
    Location
    Rotterdam, Netherlands
    Posts
    73

    Re: Touchscreen

    In the beginning of the tread second post or something

  19. #59
    Member
    Join Date
    Jan 2013
    Location
    Europe
    Posts
    60
    @aloksinha2001

    The cursor not moving would suggest that your touch interface is not supported in the android kernel. You would normally see a circle that you can drag around if it is.

  20. #60
    Member
    Join Date
    Jan 2013
    Location
    Europe
    Posts
    60
    Quote Originally Posted by maphaneuf View Post
    Hi, Where is the download file Everyone is talking about, I havent's seen any file to download

    Thanks

    I have a acer T232 HLadn wich to enalble support for Android. Any body make it wirk?
    It is in post #1 just under the quote bubble - hover over the filename or http://www.freaktab.com/attachment.p...9&d=1351462387

    As far as I know the T232HL is a newer 10 point touch that supports Windows 8 (edgeless) AFAIK I have not seen any newer 10 point screen supported in the Android kernel.

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •